play farcry 4 on dual core processors

If you’re running an old Dual Core processor you might want to pull out your hairs because the Far Cry 4 won’t work on old dual core processors. Yes, I’m talking about the Pentium Dual Core, Core2Duo and Pentium G series. The game will crash in most of the situations so in order to play it you need a modern CPU. The main problem is the game utilizes four cores and if you’re running Core i3 then you’re in luck as it will work perfectly on Core i3 but for playing it on Ultra I would recommend to buy a Core i5, Core i7 or AMD Phenom II 965BE.

However, if you’re tight on budget and want to play Far Cry 4 on your old dual core processor then we have a solution for you. You can play it by using the extreme injector v3. It’s a simple app that allows you play Far Cry 4, so download and install this app so there won’t be any crashes.

How to use Extreme Injector v3.3 on Far Cry 4:

  • First, you need to Extreme Injector V3.3. You can download it by following the link.
  • Run the program and add Far Cry 4.exe in the list.
  • Run the Game. Now, the game won’t crash on old Dual Processors. I have tested this on my old Core2Duo E7500 processor and now it works without any problem.

If you have any questions, feel free to ask in the comments section.

6 COMMENTS

  1. am having pentium dual core and nvidia geforce 210 and 2gb ram. I cant able to play farcry 4. it hangs on startup and gets closed. by using injector also i cant able to play. how to play?

    • Hi Ananth,

      The Intel Pentium Dual Core is a low end Dual Core Processor. You need to have at least a Core 2 Duo processor for playing FarCry 4 or Dragon Age Inquisuition via Extreme Injector.

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.